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About This Guide 
This user guide outlines how to install and use the PeBL InDesign plugin. It assumes that you have access to and 

basic familiarity with InDesign. The goal of this document is to provide a reference resource for the use of the 

PeBL plugin for authoring or editing PeBL-enhanced ebook content. For instructions on how to use PeBL features, 

please refer to the PeBL Usage Guide. For hardware and software requirements for InDesign, please refer to these 

Adobe requirements.  

The Term “Extension” 

There are multiple uses of the term “extension” in the technology domain. Adobe uses the term to refer to plugins, 

or software programs, that add features to one of their existing applications, such as InDesign. The term “file or 

filename extension” is used to refer to the two- to four-character suffix after the period at the end of a filename. 

However, in this document, the term “extension” always refers to the interactive components inserted into a PeBL 

ebook. 
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Installing the PeBL Plugin Using Creative Cloud 

Plugins are software programs that add features to an existing application. 

 To install the PeBL plugin for Adobe InDesign, make sure that you have installed InDesign first. Then go to the 

Adobe Add-ons website. 

1. Download the Creative Cloud desktop app. 
2. Launch the Creative Cloud desktop app and ensure that file syncing and notifications are enabled. 

Depending on your version of the Creative Cloud desktop app, do the following: 

Creative Cloud Version 1 

1. Click the gear icon in the upper-right corner.  

2. Click Syncing in the sidebar. Ensure that Pause Syncing is displayed; if not, click Resume Syncing. 
3. Click Notifications in the side bar and ensure that OS notifications, App updates, Syncing, and Adobe 

Fonts are enabled. 

Creative Cloud Version 2 

1. Click the three vertical dots in the upper right corner and select Preferences. 
2. Click the Creative Cloud tab and ensure that the following are enabled: 

■ Files > File Sync 
■ Apps > App updates 
■ Fonts > Adobe Fonts 

3. Switch to the General tab and ensure that OS notifications are enabled. 

Sign in to the Exchange portal to install your PeBL Extension.  

Once installed, you can go to My Exchange to manage your extensions. 

To find the plugin in InDesign, go to the PeBL Authoring plugin page. 

 

Source: https://helpx.adobe.com/creative-cloud/kb/installingextensionsandaddons.html 
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Create Unique, Interactive Instructional Content 

Using the PeBL plugin, you can quickly enhance InDesign content with PeBL functionality and publish it as a PeBL 

ebook. PeBL’s unique functionality includes interactive features such as discussions, linked assessment 

questions, and polling; features not available in standard ebooks. Another benefit is that, once published, your 

content can be edited and updated quickly and easily. 

PeBL Extensions allow learners to interact with each other, with their instructors, with designated experts, and 

with pre-specified external resources. In addition to the interactive content features, the PeBL plugin allows 

instructors to track, store, and monitor the progress of their learners through the use of xAPI technology. 

Overview: Using the PeBL InDesign Plugin 

There are four basic steps to using the PeBL InDesign Plugin, starting by adding interactive features to your 

content and ending with a published PeBL ebook. 

4 Basic Steps 

1. Open Existing Content or Create New Content in InDesign. 

2. Add PeBL Extensions. Click in your document where you want to add a PeBL Extension, provide the 

required details, and then click Insert. 
3. Edit PeBL Extensions. When you add a PeBL Extension, it is displayed in the PeBL Content panel. 

Selecting a PeBL Extension in the PeBL Content panel will take you to its document location, where you can 

edit it quickly and easily. 

4. Publish a PeBL Ebook. Once the content is ready, easily publish your PeBL-enhanced ebook using the 

EPUB 3 file format. 

Getting Started 

To Open or Create a New Document 

Do either of the following: 

■ Select: File > Open > Navigate to File  or press CTRL + O on the keyboard 

■ Select: File > New > Document or press CTRL + N on the keyboard 

Note:   

PeBL ebooks use reflowable text, which adapts to the device screen being used, so the page size you pick isn’t 

critical. For an approximation of the final published content, choose 475 pixels x 650 pixels. 
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Using PeBL Settings 

When the PeBL Settings dialog box is opened, it blocks any interaction with background elements until you close 

it by selecting OK or Cancel. 

To go to PeBL Settings, select:  Window > Extensions > PeBL Settings 

The settings in this dialog box take effect across the whole PeBL ebook unless they're overridden by settings in 

individual PeBL Extensions. In most cases, you will set them once, then revisit them infrequently to modify options 

and resources. 

     
The PeBL Settings dialog box 

 

Themes 

The PeBL Extension theme specifies the appearance of PeBL Extensions in the PeBL ebook. The three built-in 

themes are: Default, Gunmetal, and Rounded Blue. 

Extension Theme 

A list of available themes. When exporting, Extensions that are set to Inherit Global Theme will have the styling of 

the theme that is selected here. 
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The same Extension, exported with the three different themes. 

 

Add new theme 

Selecting this link opens the folder displaying stored theme files that the plugin can access.  

Enable Menu Bar 

Selecting this option makes a Menu Bar appear at the top of the content in the exported EPUB. The Menu Bar will 

have the following options, some of which are automatic and some of which are configurable in the Settings 

dialog box. 

 
The Menu Bar in an exported PeBL ebook. 

 

The items on the Menu Bar are as follows: 

External Resources  

A list of all of the External Resources List in the PeBL Settings dialog box. Resources can also be placed 

contextually throughout the PeBL ebook using External Resources Extensions. 

Notes 

A place for the learner to take general notes on the PeBL ebook. The Menu Bar Notes ID field in the PeBL Settings 

dialog box determines the identifier that is reported in the xAPI statement whenever the learner adds a note. 

Forum 

A place for learners to have general discussions about the PeBL ebook. The Menu Bar Forum ID field in the PeBL 

Settings dialog box determines the identifier that is reported in the xAPI statement whenever the learner adds a 

response. 
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Content Morphing 

Sets the option for a global Content Morphing group. This option only appears in the exported PeBL ebook if the 

name of a Content Morphing group is added to the Menu Bar Content Morphing Group field in the PeBL Settings 

dialog box. 

Feedback 

Provides a way for learners to provide feedback on the PeBL ebook. This option only appears in the exported 

PeBL ebook if an email address is added to the Feedback Email Address field in the PeBL Settings dialog box. 

Help Site URL 

Provides a way for learners to get help with the PeBL ebook. This option only appears in the exported PeBL ebook 

if a URL is added to the Help Site URL field in the PeBL Settings dialog box. 

Notifications 

Provides notifications for activities in PeBL ebooks within that instance of the PeBL bookshelf. Requires no 

configuration in the PeBL Settings dialog box. 

Services 

Service URL 

A place to provide the URL for the relevant installation of PeBL Services. 

Services Credential 

A place to provide the credential for the relevant installation of PeBL Services. 

Content Morphing Options 

This setting allows you to select different versions of your content for different learners. In other words, a single 

book can include multiple versions of the same content. When appropriate, the PeBL Extension can be set up so 

that a learner can switch between content based on their needs, triggers within the book, or per the instructor’s 

directions.  

It is set to Basic and Advanced by default to allow for adaptations based on a learner’s knowledge and skill, but 

there are many different ways that content morphing can be used. For example, it might be the same content 

presented in two different languages, content presented using two different methodologies, content based on two 

different assumptions or perspectives, or even content modified for two different locations. In essence, these 
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options allow you to "morph" or adapt your content for a variety of abilities and other factors. For more ideas 

about how to use content morphing, please refer to the Guide to PeBL Extensions. 

Experts 

These settings are used to specify experts who will be able to answer questions on specific content. The full list of 

experts is configured here, then individual experts can be placed contextually within the PeBL ebook using Ask an 

Expert Extensions. 

Expert List  

As experts are added, a list of experts is generated and displayed here. Each expert can be removed by clicking 

Delete (trash can icon) next to it. At a later date, this list of experts can be accessed by applicable, individual 

PeBL Extensions. 

Add Expert  

To manually add experts, select the + (plus sign) button and provide the following information:: 

Full Name Type in the expert’s full name 

Title Type in the expert’s professional title 

Description Type in a brief description about their professional expertise 

Contact Type Select their preferred contact method: email, phone, or url 

Contact Info Provide the contact info for the type selected above 

 
When done entering an expert’s information, click on Add expert. This adds the expert’s name to the list, clears 

the Add Expert fields, and more experts can be added. 

External Resources 

External resources are links to resource materials that supplement your instructional content. Your learners may 

have access to any resources you've added, depending on how you've specified them here. 

This list of resources can be accessed from your published book’s Menu Bar, if it’s enabled. One or more 

resources that you select can also be added contextually throughout the book using the External Resources 

Extension. 
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External Resources List 

As external resources are added, a list of resources is generated and displayed here. Each resource can be 

removed by clicking Delete (trash can icon) next to it. At a later date, this list of resources can be accessed by 

applicable, individual PeBL Extensions. 

Add External Resources 

To manually add resources, select the + button and provide the following information: 

Resource Title Enter a short description that will appear in the popup 

Resource URL Enter the link (URL) to the external resource 

When done entering information for a given resource, click on Add external resource. This adds the resource to 

the list, clears the Add External Resource fields, and more external resources can be added.   
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Using the PeBL Content Panel 

The PeBL Content panel can remain open while you work; it can be free-floating or docked with other panels. 

Most find docking it on the right-hand side, with other panels, to be the most helpful. 

 
The PeBL Content panel with some 

Extensions added 

 

The PeBL Content panel provides, at a glance, all the PeBL Extensions in your document as well as easy access 

to the actions used to manage the Extensions. For example, from the PeBL Content panel, you can add a PeBL 

Extension to your document. Once added, you can select it in the PeBL Content panel to view it, be taken to its 

location in your document, edit its options, preview it, and delete it. 

To go to the PeBL Content panel in your InDesign document, select: Window > Extensions > PeBL Content. 

Viewing PeBL Extensions 

The PeBL Extensions are displayed in three columns: 

Type Sorts alphabetically by PeBL Extension type 

Name Sorts alphabetically by text 

Page Sorts by page number  
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Selecting PeBL Extensions 

ACTION  RESULT 

Click 

PeBL Extension Type 

Takes you to the page in your document 

where the PeBL Extension has been inserted 

Click 

PeBL Extension Name 

Opens the PeBL Extension's Edit Extension 

dialog box, displaying editable options 

 

PeBL Content Panel Footer Icons 

The footer, or bottom, of the PeBL Content panel displays three icons: 

■ Refresh list (two arrows forming a circle) Refreshes the list of PeBL Extensions in the PeBL Content Panel 

■ Create New Extension (+ sign) Quick way for the author to add a new PeBL Extension to the  

current page; the Add New PeBL Extension dialog box is  

displayed 

■ Delete Selected Extension (trash can) Deletes the selected PeBL Extension(s). A confirmation dialog box  

is displayed. 
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Working with PeBL Extensions 

Adding PeBL Extensions 

The process for adding most PeBL Extensions is the same: 

1. Click in the document to place the text cursor where you want the PeBL Extension to appear. 

2. Open Add NewPeBL Extension dialog box from the bottom of the PeBL Content panel or go to:  

Window > Extensions > Add New PeBL Extension. 

3. Select a PeBL Extension. You will see a description of that Extension above the Add and Cancel buttons. 

Click Add.  
4. Select or Fill-in the PeBL Extension options when the Edit Extension dialog box is displayed. A 

placeholder will appear at the bottom of the Edit Extensions dialog box once the required information is 

provided. 

5. Click Insert and the PeBL Extension name will display in the PeBL Content Panel. A placeholder will also be 

inserted at the cursor location in the document, You can select, move, and delete this placeholder object 

using normal InDesign functions. 

 

Click Cancel to close the window without making any changes to your document. 

 

 
The Add New PeBL Extension dialog box 
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Standard PeBL Extension Options 

While each PeBL Extension has its own unique set of options, all PeBL Extensions include the following standard 

options: 

■ ID 

The system will generate a unique ID for you. This ID is only used when generating xPI statements, and in 

most cases, it is useful for the plugin to make sure the IDs are unique. However, if you prefer, you can edit 

the ID or provide one of your own. 

 

■ Theme 

Inherit Global Theme makes the theme for that Extension default to the theme selected in the PeBL Settings 

dialog box. Each Extension you add can override this setting. 

 

■ Insert 

Saves the options for the current PeBL Extension, closes the dialog box, and updates the InDesign file with a 

placeholder for the PeBL Extension. 

 

Note:  

If you didn’t provide all of the required options, the PeBL Extension cannot be saved and you will be notified 

when you attempt to save it. For example, a Slide Carousel Extension requires at least one image, and an 

associated caption, to be valid. 

 

■ Cancel 

Closes the dialog without saving changes. 

 

■ Preview Area 

For most Extensions, provides a live preview of the Extension with the selected options and theme. 

Discussion Extension 

Use 

Discussion questions allow your learners to learn collaboratively through threaded discussions. They can be used 

to prompt learners to share their ideas and experiences and to benefit from each other. 
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The Edit Discussion Extension dialog box 

 

Options 

■ Discussion Prompt 

Enter the question or prompt to be presented to the learner. 

 

■ Button text 

Enter text to be displayed on the button that opens the Discussion Extension. 

 

■ Discussion Sharing 

Select who the discussion will be shared with. These choices are: all, class, team, or private. “All” is selected 

initially. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 
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Placeholder 

Selecting Insert will position a labeled placeholder in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 

 
A sample Discussion Extension 

placeholder in the InDesign document 

 

Published 

The published version of the Discussion Extension is embedded in your content. In the ebook, after the learner 

selects Share, they enter their response, and then Send it to whomever was specified in the Edit Discussion 

Extension dialog box. Their response can be viewed along with  any others that have been shared. 

 
A published Discussion Extension 

 in its default state 
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A published Discussion Extension after the Discuss button has been selected 

 

Popout Extension 

Use 

Popouts can be used to customize the learner's experience so that they can access information when they are 

ready or curious. It may be used to prompt learners to pause and anticipate or recall information before answers 

are given to them, increasing their interaction with the material and stimulating recall practice. Other sample uses 

include author notes or to provide definitions or examples. 

 

17 
 



PeBL InDesign Plugin USER MANUAL 

 

 
The Edit Popout Extension dialog box 

 

Options  

■ Popout title 

Enter text for the title. This title will be displayed when the Popout Extension is shown. If using an icon is 

selected below, then this text is used as the clickable element on the published page. 

 

■ Popout text 

Enter text that you want displayed when the learner clicks on the Popout Extension title. 

 

■ Popout Icon 

Select the icon type that's most appropriate for your content. In the published book, the icon and title will 

appear on the bar that, when clicked, will reveal the content. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 
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A sample Popout Extension placeholder 

 in the InDesign document 

 

Published 

The published version of the Popout Extension is embedded in your content. After the learner clicks on the Popout 

Extension title, additional text is displayed.  

 
A published Popout Extension in its default state 

 

 
A published Popout Extension after  

the title bar has been selected 

 

Figure Extension 

Use 

Figures are used to stylize images and provide consistent information about them throughout the PeBL ebook. 

Images used in a figure can be photographs, diagrams, or any other type of image. The learner can zoom in for 

closer inspection. 
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The Edit Figure Extension dialog box 

 

Options 

■ Title 

Enter a title for the image. 

 

■ Image(s) 

Selecting Choose Files will display an Open File system dialog box where you can navigate to the image(s) 

you want to include. Click on Open and a thumbnail of the image will be displayed in the Edit Figure 

Extension dialog box. 

 

■ Caption 

Enter text for a caption. This will be displayed under the title. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 
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A sample Figure Extension placeholder  

in the InDesign document 

 

Published 

The published version of the Figure Extension is embedded in your content. 

 
A published Figure Extension 
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Slide Carousel Extension 

Use 

Slide Carousel Extensions provide the opportunity to present multiple images in a compact form. They also allow 

learners to easily compare and contrast a set of images and to build their own conclusions. 

 
The Edit Slide Carousel Extension dialog box 

 

Options 

■ Title 

Enter a title for the images. 

 

■ Image(s) 

Selecting Choose Files will display an Open File system dialog box where you can navigate to the image(s) 

you want to include. Select them before clicking on Open. 
 

If they are contiguous, you can select several images at a time by holding down the SHIFT key while you click 

on each image. 

 

After selecting Open, thumbnails of the images will be displayed on the Edit Slide Carousel Extension dialog 

box above the Choose File button. Enter text for a caption in the field on the right of each image. 
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■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 

 

 
A sample Slide Carousel Extension  

placeholder in the InDesign document 

 

Published 

The published version of the Slide Carousel Extension is embedded in your content The learner can click the left 

or right arrows to move through the images. 
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A published Slide Carousel Extension 

 

Polling Extension 

Use 

Polling questions allow the learner to share input with their peers (and with the instructor, if the PeBL ebook is 

being used in an instructor-led experience).  
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The Edit Polling Extension dialog box 

 

Options 

■ Prompt 

Enter the question or prompt to be presented to the learner. 

 

■ Responses 

Enter as many response options for the poll as you like. After entering an option, click on the + (plus sign) 

below to enter it and open up a new field for the next option. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 
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A sample Polling Extension placeholder in the 

InDesign document 

 

Published 

The published version of the Polling Extension is embedded in your content. The learner is presented with several 

responses. They select a response, then click on Share with Everyone. The Polling results are displayed on the 

VIew Responses tab. 

 
A published Polling Extension in its default state 
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A published Polling Extension after an  

option has been selected and submitted 

 

Multi-Part Text Response Extension 

Use 

The Multi-Part Text Response Extension is used to create a short-answer question with multiple parts: learner 

responses to each part can be tracked and access can be set at different levels (discussed below). Responses 

can be set to send emails with both the question and the response. 

The learner will be presented with a scrollable window with multiple questions. After each question, there’s an 

area where learners can type in their response. 

In addition to the Question Prompt, optionally, you can provide text that will be displayed in the area where 

learners type in their responses; this is referred to as a Question Placeholder.  
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The Edit Multi-Part Text Response  

Extension dialog box 

 

Options 

■ Prompt 

Enter a question or prompt that reflects the topic to be discussed. 

 

■ Questions: Question Prompt 

Enter a question about one aspect of the topic. 

 

■ Questions: Question Placeholder (optional) 

Enter placeholder text that will be displayed in the field where learners enter their responses. 

 

Press the + (plus sign) to add additional Prompt and Placeholder pairs. 

 

■ Sharing 

Select who the discussion will be shared with. These choices are: 

 

all  shared with everyone who has access to that PeBL book 

private    saved privately  

private+all  the learner has the option of sharing privately or with everyone 

private+email  the learner has the option of saving privately or emailing the response using the email app 

configured on the device (this option also saves the response in the PeBL ebook)  

team+class   the learner has the option of sharing with their team (or class), based on team/class 

options specified when logging into the PeBL ebook 

28 
 



PeBL InDesign Plugin USER MANUAL 

 
■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions 

 
A sample Multi-Part Text Response Extension 

placeholder in the InDesign document 

 

Published 

The published version of the Multi-Part Text Response Extension is embedded in your content. After the learner 

enters their responses, they select the sharing option they want. Responses, if available, can be viewed by 

selecting the View Responses tab. 
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A published Multi-Part Text Response  

Extension in its default state 

 

 
A published Multi-Part Text Response Extension 

after entries have been submitted 

 

Multiple Choice Extension 

Use 

Multiple Choice questions allow for a wide variety of instructional uses. While they're traditionally used to assess 

knowledge, and placed in groups at the end of a section, they can also be used to prompt curiosity and provide 

retrieval practice throughout the PeBL ebook.  
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The Edit Multiple Choice Extension dialog box 

 

Options 

■ Title 

Enter text for a title. 

 

■ Passing Score 

Enter a number for the passing score. 

 

■ Passing Message 

Enter text to be displayed when the learner achieves a passing score. 

 

■ Failure Message 

Enter text to be displayed when the learner does not achieve a passing score. 

 

■ Questions 

This field will display all the questions you provide. You do not type in this field; it reflects the text you enter in 

the Question text field below. Use the Move up and Move down buttons to change the order of your 

questions. You can delete a question by clicking on the delete/trash can icon on the right of the question. 

You must provide a minimum of one question (which can’t be deleted). 

 

■ Question text 

Enter the question or prompt to be presented to the learner. It will be displayed in the Questions field above.  

 

You have two ways to enter the questions and their related information: (1) enter all the questions first and 
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then provide the multiple choice responses, response feedback, and correct answer, for each by clicking on 

the question or (2) enter each question, along with its associated responses, response feedback, and correct 

answer, before adding the next question. 

 

■ Answer choices 

Enter a possible answer (be sure to provide the correct answer as well as a few distractors.) 

 

■ Feedback 

Enter feedback for a given answer choice. (This field is optional.) 

 

After entering an Answer choice (and its related feedback, if used), click on the + (plus sign) below to add 

another possible solution and its associated feedback. 

 

■ Correct Answer 

Select the correct answer from the dropdown menu. (This is created from the answer choices you provided.) 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions 

 
A sample Multiple Choice Extension placeholder 

in the InDesign document 
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Published 

The published version of the Multiple Choice Extension is embedded in your content. The learner is presented with 

several responses. They have two chances to select the correct response and feedback can be displayed with 

each answer choice. After two tries, the correct response is displayed with a green background (any incorrect 

selections are displayed with red) and the percentage of how far the learner has progressed through the 

assessment is displayed. 

 
A published Multiple Choice Extension  

in its default state 

 

 
A published Multiple Choice Extension  

after an answer has been selected 

 

Content Morphing Extension 

Use 

Content Morphing allows the learner's experience to be personalized or adapted. It can be used to provide two or 

more versions of the content, often based on difficulty level, which allows the learner to stay in their zone of 

proximal development, neither too challenged nor not challenged enough. 

Aside from difficulty level, Content Morphing can be used to customize content based on language, geographical 

information, site information, and virtually any other characteristic that might prompt multiple versions. By default, 
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the content morphing extension has two levels of content available for selection by a user, but you can add as 

many levels as you need. For example, you could have text in English, Spanish, and Chinese easily morphed using 

a dropdown selection..  

The Content Morphing Extension works differently from most of the other Extensions.  
 

Note:  

Before you insert this Extension, make sure  the content you plan on “morphing” is in your document. The 

content can be placeholder text, since you will be able to modify it later (edit, format, and embed images, videos, 

and other PeBL Extensions). Bottom line, whatever you can put in the main body of the book can be put in this 

Extension. 

 

Go to the document and click where you want your Content Morphing Extension to be located. 

 
The Edit Content Morphing Extension dialog box 

 

Options 

■ Title 

Enter text for the title. 

 

■ Show Control Icon  

Selecting this checkbox places an icon in the ebook, which becomes a control that learners can use to 

switch between Content Morphing options. In most cases, you will want to leave this checked, but if you 

want to control multiple Content Morphing Extensions using the icon on the Menu Bar, you will probably 
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want to uncheck it. 

 

■ Morphing Content 

1. Select the text in the document to be used for the first Content Morphing option. 

2. In the Edit Content Morphing dialog box, click the button Select Basic Content. To the right of the 

button, it should now display: Go to [level name]. 

3. Repeat this process with your second (and possible other remaining) option(s). 

 

The content in your document that was selected to be morphed, has been moved to separate text boxes in 

your InDesign pasteboard; you can edit it at any time. 

 

 
The Content Morphing options that have been moved into 

separate text boxes in the pasteboard 

 
 
■ ID 

This option is discussed in Standard PeBL Extension Options above. 
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■ Content Morphing Group (Optional) 

This optional field allows you to group this Extension with others. To create a group, put the same name in 

this field for all of the Content Morphing Extensions you want to be in the group. Remember, you also need 

to put this name in the Menu Bar Content Morphing Group field in the PeBL Settings dialog box. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Before you insert the Content Morphing Extension, place the cursor in your document where you want the 

Extension to be placed, then click Insert. A labeled placeholder will be placed in your document. You can select, 

move, and delete this placeholder using normal InDesign functions. 

 
A sample Content Morphing Extension 
placeholder in the InDesign document 

 

Published 

The published version of the Content Morphing Extension is embedded in your content. The Content Morphing 

Control icon will be displayed, if selected, and the learner can click it to switch between the content options. 

If displaying the control icon was not checked in the Edit Content Morphing Extension dialog box, then the 

instructor will set which content morphing option is appropriate for each reader. 

 
A published Content Morphing Extension  

in its default state 
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A published Content Morphing Extension  

after being switched to a different level 

 

Ask an Expert Extension 

Use 

Learners can use this Extension to ask questions of experts. These experts have agreed to be contacted by 

students about a particular topic and have been provided by the author in the PeBL Settings dialog box. 

PeBL Settings 

To be able to select experts for a given PeBL Extension, you must first enter information about the experts who 

have agreed to be contacted by learners. To do this, go to: Window > Extensions > PeBL Settings. 

To manually add experts, select the + (plus sign) button and provide the following information: 

■ Full Name Type in the expert’s full name 

■ Title Type in the expert’s professional title 

■ Description Type in a brief description about their professional expertise 

■ Contact Type Select their preferred contact method: email, phone, or url 

■ Contact Info Provide the contact info for the type selected above 

When done entering an expert’s information, click on Add expert. This adds the expert’s name to the list and 

clears the Add Expert fields so that more experts can be added. 
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When you are done entering all the experts, click on OK at the bottom of the PeBL Setting dialog box. 

 
The Edit Ask an Expert Extension dialog box 

 

Options 

■ Title 

Enter a title. This is only used in the PeBL Content panel. 

 

■ Button text 

Enter text to be displayed on the button that displays the list of experts. 

 

■ List of Experts 

Select the experts you wish to include for this topic by clicking the checkbox to the left of their name. You 

may select one or more. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 
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A sample Ask an Expert Extension  

placeholder in the InDesign document 

 

Published 

The published version of the Ask an Expert Extension is embedded in your content. 

 
A published Ask an Expert Extension 

 in its default state 

 

 
A published Ask an Expert Extension after the button has been selected 

 

External Resources Extension 

Use 

Learners can use this Extension to access a contextual, customized list of external resources, specified by the 

author in PeBL Settings. In addition, learners can add their own resources. 

39 
 



PeBL InDesign Plugin USER MANUAL 

 

PeBL Settings 

 To be able to select external resources for a given PeBL Extension, the author must first enter information about 

the external resources to be made available to the learners. To do this, go to: Window > Extensions > PeBL 

Settings. 

To manually add resources, select the + button and provide the following information: 

■ Resource Title Enter a short description that will appear in the popup. 

■ Resource URL Enter the link (URL) to the external resource. 

After selecting the Add external resource button, you can add additional resources. When you are done, click 

OK. 

 
The Edit External Resources Extension dialog box 

 

Options 

Open the Add New PeBL Extension dialog box by clicking on the + icon at the bottom of the PeBL Content 

Panel or go to: Window > Extensions > Add New PeBL Extension. Select the External Resources Extension, 

then click Add. 

■ TItle 

Enter a title reflecting the topic under discussion. 

 

■ Enable User Pulling of Resources 

40 
 



PeBL InDesign Plugin USER MANUAL 

 
By clicking the checkbox, external resources can be pushed by the instructor or pulled by the learners into 

the ebook. 

 

■ Button text 

Enter text to be displayed on the button that displays the External Resources. 

 

■ List of Resources 

Select the external resources you wish to include for this topic by clicking the checkbox to the left of the 

resource. You may select one or more. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

 

Placeholder 

Selecting Insert will position a labeled placeholder box in your document. You can select, move, and delete this 

placeholder using normal InDesign functions. 

 
A sample External Resources Extension 
placeholder in the InDesign document 

 

Published 

The published version of the External Resources Extension is embedded in your content. 

 
A published External Resources  

Extension in its default state 
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A published Discussion Extension after the button has been selected 

 

Show/Hide Extension 

Show/Hides allow for showing and hiding sections of text, media, and other Extensions within the published PeBL 

ebook. 

Use 

This Extension is similar to the Popout Extension, but differs in that the Show/Hide content used can be formatted 

and images, videos, and other PeBL Extensions can be added. Bottom line, whatever you can put in the main 

body of the PeBL ebook can be put in this Extension. 

Go to your document and click where you want the Show/Hide Extension to be placed. 
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The Edit Show/Hide Extension dialog box 

 

Options 

Open the Add New PeBL Extension dialog box by clicking on the + icon at the bottom of the PeBL Content 

Panel or go to: Window > Extensions > Add New PeBL Extension. Select Show/Hide Extension, then click 

Add. 

■ Title 

Enter a title reflecting the topic under discussion. 

 

■ (Show) Button text 

Enter text to be displayed on the button that will show (or display) the selected content. 

 

■ (Hide) Button text 

Enter text to be displayed on the button that will hide the selected content. 

 

■ Default State 

Choose either hidden or shown as the default state. 

 

■ Content 

Before pressing the Select Content button, confirm the text you want to show/hide is selected in your 

InDesign document. 

 

Select Content: Select Content button. 
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The text is removed from the document and placed on your InDesign pasteboard. You will also see it in 

the Show/Hide preview at the bottom of the Edit dialog box. 

 

■ ID 

This option is discussed in Standard PeBL Extension Options above. 

 

■ Theme 

This option is discussed in Standard PeBL Extension Options above. 

Placeholder 

Selecting Insert will place the content on the pasteboard, where you can edit and format it, add images and 

videos, and add other PeBL Extensions. 

 
A sample Discussion Extension placeholder in the InDesign document and the 

content that has been moved into a separate text box in the pasteboard 

 

Published 

The published version of the Show/Hide Extension is embedded in your content. When the content is in the 

selected default mode, in this case hidden, you only see the button. 

 
A published Show/Hide  

Extension in its default state 
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A published Show/Hide Extension 
 after the button has been selected 
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Publishing Your InDesign Document as a PeBL eBook 

Transforming your content into an interactive ebook is relatively simple. 

Export Your Document to an EPUB 3.0 Format 

1. Make sure that you have saved your content as an InDesign 

document. 

2. You publish your ebook by exporting it, which converts it 

from an InDesign file format to a PeBL ebook format. 

 

Select:   File > Export and an Export dialog box will be 

displayed 

or press CTRL + E on the keyboard. 
 

3. Specify where you want the file to reside, name the file, and 

specify the format of the published book using the “Save as 

type” dropdown menu, making sure the file type is: EPUB 

(Reflowable) (*.epub) 

 

4. Click Save. 
 

5. The EPUB Reflowable Layout Export Options dialog box will be displayed.  

Verify that the version is EPUB 3.0 or your PeBL Extensions will not work correctly. 
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If not already selected, click on General in the left-side menu. The version selected should be: EPUB 3.0. If it 

isn’t, use the dropdown menu to select it. 

6. Click on OK to create the exported EPUB 3.0 ebook. 

7. At this point, you may be asked to select an app to open the exported file. You do not need to associate a 

specific app with the file or .epub file format. 

Viewing Your PeBL eBook 

1. Open a browser window to the location where you saved 

your ebook 

2. Using File Explorer or Finder (or open another browser 

window), go to the PeBL Reader at reader.peblproject.org 

3. Position your two windows so that you can drag your ebook 

file or icon to an empty location on the Reader page. 
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4. Drag the file to the Reader window; it can say either Copy or Move, just make sure that you see the purple 

glow around the perimeter of the window before releasing the file. 

The published ebook should now be displayed in the Reader window. 

Published Extensions 

To see an example of how a PeBL Extension will look when published, go to that Extension’s section in this User 

Guide. ◼ 

   

48 
 



PeBL InDesign Plugin USER MANUAL 

 

Resources   

Adobe InDesign Resources 

■ System Requirements - Hardware requirements for Adobe InDesign 

■ Add-Ons Website - A marketplace for InDesign extensions. 

■ Creative Cloud Desktop App - Installs and updates your InDesign extensions. 

■ Adobe My Exchange - Allows you to manage your InDesign extensions. 

■ Extension Installation Help - A resource for help with installing and managing InDesign extensions. 

PeBL Resources 

■ PeBL Specification - Covers the technical details of PeBL including code examples for every PeBL 

feature, an explanation of the PeBL architecture, and more. 

■ Adding xAPI to ebooks - Covers the technical details of how to add xAPI data reporting to ebooks, 
including examples from PeBL. This document is available as part of the PeBL documentation. 

■ PeBL xAPI Vocabulary - This is a list of the xAPI vocabulary used by PeBL. For feature-specific details, 
refer to the PeBL specification. 

■ PeBL eReader Compatibility Matrix - This matrix shows the PeBL compatibility for many common 
eReaders. 

■ PeBL Compatibility Test ebook - This ebook automatically tests and reports an eReader’s PeBL 
compatibility. This ebook is available as part of the PeBL installer. 

■ PeBL Community Forums - For questions and discussion of PeBL features, use, and implementation. 

Additional Technical References 

■ IDPF EPUB 3.1 

■ ADL Experience API (xAPI) 

■ EPUB3 Scriptable Components 

■ EPUB3 Scriptable Packaging and Integration 

■ HTML5 

■ CSS 

■ W3C Accessibility 

■ Javascript Web APIs 
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https://helpx.adobe.com/uk/indesign/system-requirements.html
https://creative.adobe.com/addons
https://helpx.adobe.com/download-install/kb/creative-cloud-desktop-app-download.html
https://exchange.adobe.com/my-exchange.html?cloud=cc
https://helpx.adobe.com/creative-cloud/kb/installingextensionsandaddons.html
https://peblproject.org/specification.html
https://peblproject.org/definitions.html
https://peblproject.org/compatibility.html
https://peblproject.org/forum/
http://www.idpf.org/epub/31/spec/epub-spec.html
https://github.com/adlnet/xAPI-Spec
http://www.idpf.org/epub/sc/api/
http://www.idpf.org/epub/sc/pkg/
https://www.w3.org/TR/2014/REC-html5-20141028/
https://www.w3.org/standards/techs/css#w3c_all
https://www.w3.org/standards/webdesign/accessibility
https://www.w3.org/standards/webdesign/script

